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Abstract
Electron gun high voltage conditioning data analysis
Francisco Valerio-Lopez (Benemerita Universidad Autonoma de Puebla, Puebla, Mexico
72592) Carlos Hernandez-Garcia (Thomas Je↵erson National Accelerator Facility,
Newport News, VA 23606).
Field emission is a process in which a metal surface emits electrons due to the presence of a high electrostatic field. Even after the best polishing and cleaning practices,
field emission from particulates and nano-protrusions is the primary mechanism limiting
maximun achievable bias voltage in DC high voltage photoemission electron guns used
at Je↵erson Lab. Gas high voltage conditioning eliminates field emission from electrode
cathodes used in these guns. It is a lengthy and delicate process that if not done carefully
may lead to catastrophic failure. Furthermore, its behavior and success depends on electrode geometry. Several electrodes of various shapes have been high voltage conditioned
over the past few years, but the amount of data for each conditioning run makes the
analysis of the conditioning process very difficult. In this work, thousands of data points
collected for each conditioning run were analyzed to characterize each electrode shape
in regards to field emission onset voltage, cumulative processing time, maximum voltage
required to eliminate field emission, and field emission activity. An algorithm was made
in Python capable of reading and filtering the raw data. Three electrode shapes have
been analyzed; Tee with no shield electrode at the ceramic-electro interface, large shield
electrode, and small shield electrode. Both shielded electrodes were designed for 200kV
operation compared to the 100 kV Tee electrode. Knowing the behavior of high voltage
conditioning will serve as a baseline about expected behavior, as a guide in designing
future electron guns and for planning the length of time required in their high voltage
conditioning phase.
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Introduction

Several high energy and nuclear physics experiments are conducted using spin-polarized electron beams produced by illuminating a GaAs photocathode inside a direct current (DC) high
voltage photogun with circularly polarized light. The vacuum conditions must be below 10 9
Pa to mantain a reasonable photocathode operating lifetime. At most facilities, the photocathode is biased at 100 kV and today’s DC high voltage photoemission guns require electrodes
capable of operating at 100-400 kV and at field strengths of the order 10 MV/m to provide
high brightness electron beams for accelerator applications. However, above 100 kV there are
operating complications, mainly due to the presence of field emission [1]. Low level field emission from the cathode electrode has the e↵ect of degrading the vacuum which in turn reduces
the photocathode lifetime due to ion bombardment. High levels of field emission can damage
the photogun components, in particular the high voltage insulator. Furthermore, field emission generates x rays which can in turn generate unwanted photoemission from the cathode
electrode, amplifying the ill e↵ects of ion backbombardment and chemical poisoning [2]. Gas
conditioning, using helium and krypton gas, was shown to eliminate field emission from cathode electrodes used inside these guns, thus providing a reliable means to operate photoguns
at higher voltages and field strengths. Measurements and accompanying simulation results
obtained in previous experiments [3] suggest that gas conditioning e↵ectively eliminates field
emission sites via sputtering but also as a result of ion implantation which serves to increase
the work function of the electrode.
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Electrodes geometry

Three di↵erent shapes for the electrode have been analyzed during the gas conditioning experiments carried out between 2018 and 2019 at the Upgrade Injector Test Facility (UITF) and
at the Continuous Beam Accelerator Facility (CEBAF). The three electrodes have an invertedinsulator geometry design. There are two reasons for it: first to provide a smaller volume which
could result in better achievable vacuum because there is less surface area to contribute a gas
load; and second, the insulator serves as the electrode support structure, which means there is
less metal biased at high voltage and less metal to contribute to field emission. Figure 1 shows
the three analyzed electrodes.

Figure 1: Photographs of the three electrodes used for gas conditioning.
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The first one is known as the Tee electrode, it is machined from solid stainless steel 316L,
diamond paste polished and it was evaluated at 230 kV with kypton gas conditioning at UITF.
The remaining two electrodes (known as Small Shield and Large Shield electrodes) also have
the inverted gun design and are machined from SS 316L, but the di↵erence lies in the implementation of the centrifugal barrel-polishing (CBP) process. The small shield electrode was
installed in UITF gun, it first was processed to 220 kV with kyrpton gas conditioning, and
then the electrode delivered electron beams at 150 kV and later at 200 kV in ultrahigh vacuum
conditions, meanwhile the large shield electrode was installed first in the UITF gun, processed
to 220 kV with krypton gas, and later on CEBAF generated electron beams at 200 kV under
vacuum conditions with field emission.
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Obtaining Datasets

During electrode gas conditioning, the values for the photo gun voltage, current, radiation
level, and vacuum were recorded. Because conditioning is a very long process that spans up to
days, the raw data set for these parameters includes extended periods of time where readings
are close to zero, which for analysis purposes can be considered noise. Figure 2 is a graphic
example of what we said earlier, the voltage record is shown in blue, the current record in red,
the radiation level record in magenta, and the vacuum record in green. It is very easy to notice
the prolonged periods of inactivity for each parameter, these data complicate and have nothing
to contribute to the e↵ective conditioning process, so it is possible to get rid of them.

Figure 2: Graphs for raw data of voltage, current, radiation and vacuum.
The first thing to do is obtain the data set of the conditioning period of the electrode that
needs to be studied, for this,just follow the instructions below:
mySamplerTo run mySampler and get electrode HV processing data:
1. To run mySampler, first type ssh itfl01 or any other fiefdom like opsl01. This will give you
access to write files to your home folder.
2. Once in the desiderd fiefdom and from the terminal type, for example:
mySampler -b “2019-08-27 15:00” -s 60s -n 3840 IGLK100HVPSkVolts
IGLK100HVPSmAmps UITFDECRAD03>GTS Conditioning 1minute 27Aug2019.txt
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3. Use the proper start date and time for the desired data set.
4. Use the proper signal names for the desired system. For example, the Isignal names in the
example above correspond to the UITF system. You will need to change these for the CEBAF,
GTS, and LERF systems accordingly.
5. n is the number of samples, that is, the total number of minutes in the desired sample period,
which can be several days. If there are many days between high voltage conditioning runs, we
often break the mySampler data gathering in two or three sections to prevent acquiring null
data and making the output file too big.
6. You can send the file via email.
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Changing the file format

After following the previous instructions, a TXT file is generated that contains the records for
voltage, current, radiation and vacuum, or the parameters that are required for the analysis.

Figure 3: Raw dataset example.
The two commonly used text file formats are:
1. Delimited text files (.txt) in which TAB character typically separates each field of
text.
2. Comma separated values (.csv) in which the comma character (,) typically separates
each field of text.
The TXT file must be converted into a CSV file, since its necessary for the Python’s library
used in this work [4]. This can be done in Excel and there is a good reason for it: it is easier.
Excel’s capability for manipulating data just selecting columns through a click allowing the user
to write a new file with a desired format in just a couple minutes is pretty useful for managing
enormous data files.
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The first way to do it will be explained next; you can open a text file as an Excel workbook
by using the Open command. Opening a text file in Excel does not change the format of the
file. The next steps can be followed:
1. Go to File > Open and browse the location that contains the text file.
2. Select the Text Files in the file type dropdown list in the Open dialog box.
3. Locate and double-click the text file you want to open.
Note: You can import or export up to 1,048,576 rows and 16,384 columns.
Since a TXT file is being imported, Excel starts the Text Import Wizard. When you are
in the Text Import Wizard - Step 1 of 3, make sure to click on the Delimited markbox
in the Original data type section and check the My data has headers box. Click on Next
button.

In the Text Import Wizard - Step 2 of 3, click on the Space box in the Delimiters
section. Note that after clicking on that box, some lines that delimits the columns appear in
the Data preview .

Finally, in the Text Import Wizard Step 3 of 3 window you can leave the boxes as they
are and click finish to complete the data import.
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By doing this Excel creates a workbook with the imported data. You can now select only
the columns for voltage, current, radiation and vacuum and then create a sheet with the New
sheet button.

The next step its important, since you are going to copy-paste the selected columns on the
Sheet 1 that you have created in the preceding step, placing it on the B1 cell, as depicted in
the next picture.

This is done like this since a space must be keep for the Time column. This column is added
manually, by writing, first, on the A1 cell: ’Time (minutes)’. And then wrting
• ’0’ in the A2 cell
• ’1’ in the A3 cell
• ’2’ in the A4 cell
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Next, you will select from the A2 cell to the A4 cell and then drag down the mouse until
you reach the end of the rows. This will auto-fill the Time column from 0 to the last row value.
You must be patient on this step. For simplicity, it is convinient to rename the column headers,
be sure to write:
• HV (kV) instead of IGLK100HVPSkVolts.
• PS Current (mAmps) instead of IGLK100HVPSmAmps.
• RadMon (CPS) instead of UITFDECRAD0X.
• Vacuum (Amps) instead of VIP2I01c.

Sometimes the raw datasets have undefined values, so you also need to get rid of those null
values. In order to do that you can use the Find and Select tool. On the Home tab, click
Find and Select > Replace...
In the Find and Replace dialog box, write:
• Find what: <undefined>
• Replace with: 0
Also, make sure to select: WIthin: Sheet and
Search: By columns.
That will find all the values in the columns that includes the string ’<undefined>’ and will
replace it with 0’s. The final step is to export this workbook to a CSV file. Go to FIle >
Export > Change File Type > CSV (Comma delimited) > Save As. Name the file as
you want and make sure to click the OK button to save only the active sheet.
This completes the tutorial to obtain the data required for the conditioning analysis of a
particular electrode, in addition to changing the format of the set.
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Data filtering

The work regarding data filtering was written in a Jupyter Notebook through the Google Colab
platform. The reason for this is because this work is intended to be a technical note for future
related work within the Sources and Injectors group, the accessibility and friendly interface of a
platform like Colab is more than adequate for this. You can access to that notebook by clicking
the following link: Electron gun high voltage conditioning data analysis - Jupyter Notebook
link. Once in the notebook what you need to do is upload the CSV file that has been created
in the previous section. To do this, go to the left section of the webpage, under the Colab logo
and click on the Files icon, then click the Upload to session storage button. This will open
your local storage where you can select the CSV file. Please note that uploaded files will be
deleted when the runtime session is recycled. As an example, a file for the UITF Small shield
electrode conditioning in vacuum will be used.

Once this is done, the CSV file will appear in the Files section. After that, in a code cell, the
following libraries need to be imported.
import
import
import
import

pandas as pd
numpy as np
seaborn as sb
matplotlib.pyplot as plt

You can use Shift + Enter to run a cell, or click on the Play button at cell’s top left. Using
the Pandas library function: dataframe = pd.read csv(‘your uploaded file name.csv’),
the uploaded CSV file is readed in another code cell, and with dataframe.head() display the
first elements of the dataframe.
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data = pd.read_csv('UITF_sm_shld_11_and_18_Nov_19_vacuum.csv')
data.head()

The value of the notebook is that after this, you only have to press Ctrl + F9 (for Windows
users) or or go to the Runtime button and click Run all to run the code that generates the
filters for the data and the graphs, as well as a new CSV file with the filtered data. Data
needs to be filtered based on column values. In this case, the interest focuses on positive values
for the voltage of the electron gun. Lets declare a variable, called data voltage filter. The
definition of that variable uses the dataframe defined in the cell above and as argument, only
looks for the elements on the column HV (kV) that are greater or equal to zero. Next,the
function dataframe.reset index() is called. This function does exactly what its name says:
resets the index of the data frame. We’ll see in a few why this is something convinient to do.
data_voltage_filter = data[data['HV (kV)' > 0]]
data_voltage_filter.reset_index(inplace = True, drop = True)
data_voltage_filter.head()

It should be noted that after applying the filter to the voltage column, it only returns the
values that meet the imposed condition. Therefore they are not always sequential values and
we can expect jumps between time values. That is the utility of resetting the dataframe’s index
since it can be considered as a cumulative time for the values that interest us to the electrodes
conditioning. To get a quick graph for this filter, just write in another cell dataframe.plot().
The arguments for this function are use index = True to state that we want the index of our
dataframe as the x-axis, and we define the y-axis as the column value we want to plot.
data_voltage_filter.plot(use_index = True, y = 'HV (kV)')
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The same filtering process can be applied to any of the columns of the data file, with the
conditions that the study needs to meet, for further data filtering reference visit the notebook.
The dataframes generated by the filters can be exported to new CSV files using the function
dataframe.to csv(’your new file name.csv’) where you can give this file the name you
want, after running that cell your file will appear in the Files section. Be careful to use the
argument index = True in order to include the index generated with the filter.
data_voltage_filter.to_csv('UITF_sm_shld_11nov_vacuum_filtered.csv', index = True)
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Results

Five conditioning runs, in ultra high vacuum and with partial pressure of krypton gas, were
analyzed using the methods described above. For the runs with Kr, the three electrodes were
processed at the UITF, while for the two runs under vacuum conditions, the large shield electrode was conditioned at CEBAF and the small shield at the UITF. The parameters chosen to
be analyzed in detail were the voltage registered for the photogun, in kV, and the radiation, in
counts per second (CPS), since in this way it is possible to relate the increase in field emission
caused by the application of a high voltage.
Figure 4 shows the obtained graph for the kyrpton gas conditioning of the Tee electrode. For
this electrode, the time needed to process out field emission was about 32 hours (left graph),
and the voltage to do so was about 230 kV as shown by the graph to the right, which is a scatter
plot of field emission induced radiation detected by Geiger-Muller monitors, as a function of
applied voltage.
The conditioning time for the Large shield electrode (Figure 5) was similar to the small shield
electrode (Figure 6), but the field emission activity was significantly higher, even though the
voltage required to extinguish field emission was similar to that for the small shield electrode.
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Figure 4: Voltage vs. Cumulative Conditioning time (left) and Radiation vs Applied voltage
for Tee electrode in UITF (Kr conditioning) (right)

Figure 5: Voltage vs. Cumulative Conditioning Time (left) and Radiation vs Applied voltage
for the Large shield electrode in UITF (Kr conditioning) (right).

Figure 6: Voltage vs. Cumulative conditioning time (left) and Radiation vs Applied voltage
for the Small shield electrode in UITF (Kr conditioning) (right).
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In addition to gas high voltage processing, two electrode shapes were high voltage conditioned under vacuum conditions. Figure 7 shows that the cumulative time in vacuum conditions
for the large shield electrode was about 27 hours meanwhile for the small shield electrode took
about 60 hours. Field emission was not completely extinguished as seen in both of the scatter
plots. Unfortunately the high voltage conditioning time had to be cut short due to schedule
constraints.

Figure 7: Voltage vs. Cumulative conditioning time (left) and Radiation vs Applied voltage
for the Large shield electrode in CEBAF (high vacuum) (right).

Figure 8: Voltage vs. Cumulative conditioning time (left) and Radiation vs Applied voltage
for the Small shield electrode in UITF (high vacuum) (right).
Comparing now the behavior of all three electrode shapes in a single scatter plot (Figure 9,
left graph) during krypton gas high voltage conditioning, one can see that field emission onset is
about 100 kV and is independent of electrode shape. In contratst, the highest voltage required
to eliminate field emission is shape dependant. For example, the Tee electrode required 230kV,
but the Large shield electrode required 220kV.
For the electrodes under vacuum conditions (Figure 9, right graph) we can see field emission
behavior between the small shield and the large shield electrodes, both when conditioned under
vacuum conditions. Notice that the large shield electrode exhibits higher levels of field emission
for the same voltage compared to the small shield electrode.
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Figure 9: Comparison of Radiation vs Applied voltage between the Kr gas conditioning electrodes (left) and under high vacuum conditions (right).
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Conclusions

The graphs presented in the previous section indicate that the signal reported by the radiation
detectors is much more scatter for the Kr gas high voltage processing case than in the vacuum
high voltage conditioning case. The graph on the right looks very similar to that in previous
electrode field emission studies under vacuum conditions. We will be exploring potential mechanisms to explain the di↵erence. In addition to the di↵erence in radiation signal behavior, it
is noticeable that the field emission onset in vacuum conditions is about 130kV, while that in
krypton gas conditions is much lower, about 100 kV.
As final conclusion remarks, we can list the following statementes:
• Field emission onset voltage is independent of electrode shape.
• Field emission activity depends on electrode shape.
• Highest voltage needed for eliminating field emission depends on electrode shaping.
• Radiation vs voltage curves are very di↵erent for vacuum conditioning compared to gas
conditioning.
Knowing the behavior of high voltage conditioning will serve as a baseline about expected
behavior, as a guide in designing future electron guns and for planning the length of time
required in their high voltage conditioning phase.
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